Which server port does DNS use with both UDP and TCP?

DNS uses port 53 with UDP and TCP.

Start playing free

  1. Port 25
  2. Port 67
  3. Port 53 ✔

Why: Standard DNS queries commonly use UDP port 53 because it has low overhead. DNS also uses TCP port 53 when reliable stream transport is required.

Huh, didn't know that: The transport protocol is part of an endpoint, so UDP 53 and TCP 53 are distinct sockets.

The dad joke
DNS found port 53 by looking up its number.
Like this card?
Play the game

References

Answer: Port 53. Standard DNS queries commonly use UDP port 53 because it has low overhead. DNS also uses TCP port 53 when reliable stream transport is required.

  1. RFC 1035: Domain Names, Implementation and Specification www.rfc-editor.org/rfc/rfc1035.html
    The Internet supports name server access using TCP [RFC-793] on server port 53 (decimal) as well as datagram access using UDP [RFC-768] on UDP port 53 (decimal).
    Checked 2026-10-11.

Think this answer is wrong? Tap "Challenge this answer" on the card in the game and tell us why.

Test yourself in the game